Connection failures for organizations restricting GitHub access by IP address

Official Claude incident record with affected components, status, timeline updates, and links back to relevant status checks.

Affected components

These are the official Claude components attached to this incident. Component data can help separate a web app issue from an API, Console, or Claude Code issue.

claude.aiClaude Code

Official timeline

Updates are shown from the official Claude status incident record.

resolved

This incident has been resolved.

monitoring

A fix has been implemented and we are monitoring the results.

identified

We have identified an issue affecting organizations that restrict GitHub access by source IP address. A recent infrastructure change altered the IP addresses Anthropic uses for outbound connections to GitHub, which may cause Claude Code remote sessions, GitHub Enterprise plugin syncing, and Claude Security to fail. We are reverting the change to restore the previous IP ranges; no allowlist changes will be needed on your side. We will post an update once the fix is deployed.